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ToMa  

Overview 
The DGT Tournament Manager (ToMa) is an application to publish chess games played on DGT 
electronic chess boards to internet or local screens in the playing hall. 
ToMa works with Windows XP and Vista. 
 

 
 

Programs 
ToMa exists of different programs which have their own specific function and together are a strong 
team. ToMa can be used in a networked environment with multiple computers. ToMaPro, the main 
program, works as the server and the other applications are its clients. The following applications are 
used to get a correct working publishing: 

·  ToMa Pro, the main program. 
·  ToMa Board Communicator (BoCo), to be used on every PC with connected chess boards. 
·  ToMa Traditional Display Client (TDC), for local display of one or more games on a monitor. 
·  ToMa FTP Uploader (FTPuP), for publishing changed games to the internet. 

 
Optional the ToMa Video Chess Show (TVCS) can be used where the user can modify the game 
presentation to his own wishes. 
 
Within a network just one instance of ToMaPro can be used. Per computer only one instance of the 
BoCo can be used to communicate with the electronic chess boards. On each computer multiple 
instances of the TDC and the TVCS can be run. Including on the computer where ToMaPro runs. The 
complete package can run on one or more computers in one network. An example of multiple 
computers in a network is shown in Figure 1. 
 

 
Figure 1 
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Checklist 
To check if your ToMa and electronic board setup works, a simple checklist has been created below. 
Explanations are made in the rest of the document. The checklist contains the steps to do a set-up 
and help the user with reminders. 
 

o DGT e-boards, pieces and clocks are set-up 
o The e-boards are connected to a PC through cables in the network structure 
o ToMaPro is started 
o One or more Board Communicators (BoCo) are started 
o On every BoCo: Select the communications port to use 
o On every BoCo: Select the cabling type to use 
o On every BoCo: Connect to the ToMaPro, check if all boards are connected 
o For every BoCo Check if the boards are showing up in ToMaPro 
o Start recording 
o Check if all boards are being recorded 
o In ToMaPro: edit tournament information 
o In ToMaPro: start new round, fill out necessary information 
o In ToMaPro: create internet Flash display site 
o In ToMaPro: start FTPuP to upload the live games (and/or the PGN) 
o Check the internet if the games are shown 
o In ToMaPro: game information is added 

To Start 
Before using ToMa the following should be taken care of: 
 

·  A computer with one or more connected DGT e-boards (see Scheme for board cabling). 
·  ToMa must be installed on this computer. 
·  The boards are connected through the BoCo. 
·  For multiple boards a ToMa license is necessary (see Register ToMa). 

 
For publishing to the internet the following must be available: 

 
·  A working connection with the internet. 
·  A web site where you can publish the files with FTP access. 
·  User name and password for the FTP to login. 

 

Installation 
The ToMa setup program can be downloaded from http://www.dgtprojects.com/toma_download.htm. 
This installs the files default to C:\Program Files\DGT Projects\TOMA\X.Y (where X.Y is the version 
number). 
 
If you have a firewall active and ToMa starts for the first time, the firewall will ask if ToMa must be 
blocked. In Windows XP this looks as shown below in Figure 2. 
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Figure 2 
 
ToMa must always be unblocked, even if it runs only locally. Otherwise no communication will take 
place between the different ToMa applications.  

The ToMa Board Communicator 
The Board Communicator (BoCo) can be started from the ToMaPro (Windows) menu when the 
ToMaPro is running on the computer. Otherwise it can be started from the Windows Start menu: Start 
-> DGT Projects -> ToMa -> Board Communicator . On each computer with physically connected 
boards only one instance of the BoCo may run. Depending on the ports, protocols and the number of 
boards, the BoCo can show like Figure 3 and Figure 4. 
Tab Connect e-boards : 
 

 
Figure 3 
 
 
Select all wanted checkboxes in the column Port : 
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Figure 4 
 
In this example there are two boards connected with bus cabling (see Scheme for board cabling) 
through the serial port COM1 and one board through a USB connection (COM3 USB). On the second 
USB port (COM4 USB) a serial to USB converter is connected with no boards. 
It takes a few seconds before all the boards are recognized and connected.  
When there are less boards showing than the real number of connected boards with the serial cabling, 
check and repair if necessary the cables. Then restart  the BoCo. 

Column description: 
Port De type and number of the port on the computer. 
Cabling type USB, Serial or Serial Bus. 
# Connected The number of connected boards, auto in case of Serial Bus. 
# Active The number of boards that has connection with the BoCo. 
 
Click on the button ‘Connect” to connect to the ToMaPro server and sending all information and 
changes on the boards. As long as the ToMaPro is not running and active, the BoCo tries to connect. 

 
Figure 5 
 
As soon as the connection is made, the lower part of the screen will change to the Figure 6 situation. 

 
Figure 6 
 
The Overview tab can be used to get more information about the connected boards (Figure 7). 
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Figure 7 
 
Column 1 The number of data packets per second received from the board, maximum is 3. 
Board Shows the serial number of the board. This can also be found on the side of the e-

board. 
Table Optional, to add the table number. This is not forwarded to ToMaPro 
Sca The number of scans, which is the number of changes in the board positions. 
 White The white clock value if a clock is connected. Greyed out if the clock is not yet 

running. 
 Black The black clock value if a clock is connected. Greyed out if the clock is not yet 

running. 
Errors The total number of errors during reading the information from the board. The errors 

are automatically repaired and are normally no real problem. 
Whiteplayer Optional, the name of the white player. This is not forwarded to ToMaPro. 
Blackplayer Optional, the name of the black player. This is not forwarded to ToMaPro. 
 
To check for the current situation on the board double click the row of the board. Each board can be 
shown separately. Spread the windows over the screen to get some overview. 
 

 
Figure 8 
 
In the Settings  tab the user can change the network settings. Default these settings are automatically 
detected and for the most cases this works perfect. 

Important 
Do not close the BoCo during the use of ToMaPro or during recording of the games. This will lead to 
loss of information, e.g. missing moves or lost games. Close the BoCo after everything is finished. 
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Serial boards through USB 
Nowadays new computers do not have serial ports anymore, but they have multiple USB connections. 
There are Serial to USB converters available. The BoCo sees this converter as a USB connection and 
under “cabling type” show automatically USB.  To convince the BoCo there is a serial bus behind this 
port, the setting must be switched to “Serial Bus”. This must  be done before checking the check box 
and before connecting with the ToMaPro server. 
It is possible to use a maximum of 127 USB connections through a USB hub. However for real 
tournament situations the serial bus structure is advised as the best solution. 
 

 
Figure 9 
 
 
In the #Connected  column the word auto is given and after some time the number of connected 
boards shows up in the #Active  column. 

ToMaPro 

The ToMaPro screen 
After starting up ToMaPro and depending on the connected number of BoCos, the screen will show 
something like Figure 10. If no BoCos are connected, no games are created in the list in the lower half 
of the screen. 
 
ToMaPro starts automatically a round without a name containing all connected boards. Boards from 
BoCos on different computers in the network will be shown. 
 
Check the serial number in the column recording with the connected boards via de BoCos. Each 
board starts with the text “DGT”, the board serial number and “OK”.  
When the board number is enclosed in "<>", then this board number may be entered by hand or is 
imported from a PGN file. This board is not physical connected to the computer. This is the case with 
board 2 in figure 10. 
The board number can be followed by "OFF" which means that the connection to this board has failed. 
Like board 3 in figure 10. 
 
If a row is clicked, the left board shows the actual situation on the board. The right board shows the 
game. On the right side the game notation is shown. The right board and the game notation only show 
legally correct moves. If an illegal move is detected, the recording of the game stops! 
 



Manual ToMa 1.6  

 9 

 
Figure 10 

The left board 
On the left board the current situation on the board is shown, independent of the rules of the chess 
game. With every change on the board a scan is send to the BoCo and forwarded to the ToMaPro. If a 
piece is lifted and put back at the same spot or anywhere else on the board, this will result in two 
scans. 
 
With the buttons at the bottom of the left board the different scans can be shown. The following 
buttons are from left to right: first scan, previous scan, next scan and last scan.  

 
 

 
Figure 11 
 
The two buttons on the right are described in the chapter Solving problems. 

The right board 
On the right board the played game and game notation can be seen, according to the rules of the 
chess game.  
 
For the pieces in the game notation the English abbreviation is used: K = King, Q = Queen, R = Rook, 
N = kNight, B = Bishop. 
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Figure 12 
 
A recording of a game on an e-board can start only when both the left and the right board show the 
same position. Normally the game starts from the start position, which is recognized by the software. 
 

Short or long notation 
Just under the game notation is a checkbox for selecting long notation, e.g. Ke1-e2. If not selected the 
short notation is used, e.g. Ke2. 
 

Comment field 
Below the game notation there is a text box for adding comment to the current selected move. This 
comment is added to the PGN file if this is selected in the round information form. 

Publishing a tournament 

Tournament data 
Before publishing all kinds of data can be added. The first thing is the tournament information. This 
information is later used with the round information (see Figure 13 and Figure 14). 
 

 
Figure 13 
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Figure 14 

Round information 
The next step is adding the round information. This changes every round. Choose Edit -> Round  and 
fill out the form that pops up (see Figure 15). 
 

 
Figure 15 

Round settings 
Usually it is useful to name the round like ‘Round 1’, ‘Round 2’, etc. Select the checkbox ‘Move 
recording’, which enables move recording automatically for all games in this round. 
 
The variations on the chess rules are given in an appendix. For normal chess select ‘Normal Chess’.  

Live broadcasting Settings 
For publishing the round on the internet or to a PGN file for broadcasting, here the settings must be 
made. First a directory on the local computer must be made for storing the data locally before 
publishing it on the net. The advice is to make a directory for each round. 
 
Autosave to PGN creates a PGN file on the given location. This file contains all games of this round 
and is updated whenever a move is played on one of the e-boards. If this field is left empty, no file will 
be created. If the DGT XL clocks are used with the boards, you have the possibility to store the times 
per move into the PGN file by checking the ‘Include clock times in PGN’ checkbox. The DGT advice is 
always to create this file, even if you do not publish live on the internet. 
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The suggested file name contains the names of the players. It is better to just give it the name of the 
tournament plus the name of the round. All games are stored in this figure (see Figure 16). 
 

 
Figure 16 
 
Create ToMa Flash Display site 
Choose a local directory where the data for the graphical view of the games on the internet have to be 
stored. Choose a different directory for each round. 
 
In this directory a HTML file, an Adobe Flash file and data files will be stored and uploaded. On the  
Internet it looks like Figure 17. The end user can select the game to follow, move by move. 

The given time is always the time of the last played move and does not change when the game is 
replayed. 
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Figure 17 
 
Later in this manual the steps for uploading the games to internet are described. Check out the 
appendix Changing the ToMa Flash Display page if more than 4 games are to be shown. 

Game data 
Tournament and round 
Per game several data must set. Select Edit -> Game for a pop-up form to fill out. The tournament 
name can be selected from a drop down box or added by clicking on the button behind the box. Same 
goes for the round data. 
 
Game settings 
At Name of game the table number can be used. Normally only a number is used here. The date 
becomes automatically today’s date. The names of the players are also added here. See Figure 18 
and Figure 19. 
 
It is also possible to add this information from a pairing program. See Using Fide reports for an 
explanation. 
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Figure 18 
 

   
Figure 19 
 
Broadcast settings 
For displaying games on local monitors the settings for broadcasting must be filled out. The ‘Send to 
ToMa Display Client’ box is empty until somewhere on a computer in the network a TDC is started. 
Then you can select the monitor to show this game on. 
 
With selecting the ‘Panic Mode’ or the scans from the board will be shown on the TDC or the game. 
The TDC always uses the short algebraic notation (SAN) for displaying the moves. 
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By selecting a file or filling out a file name in the field Autosave to file the game can be stored in a 
separate PGN file. By checking the Include clock times in PGN checkbox, also the clock values will be 
added to the PGN file as comment with the move. It is not necessary to use the Autosave to file when 
this is also used in the round settings. 

Using Fide reports 
It is possible to import a FIDE report generated by a pairing program for easy addition of names and 
games in a round. The base is the default FIDE report. When a new pairing is available, export it to a 
FIDE report in text format. In ToMaPro open File -> Import games from FIDE  which shows a form. 
Select in this form the tournament and select the generated FIDE report. Then select a round in the 
drop down list "Select round" Per e-board it is now possible to select the white player or the black 
player. The other player will be added automatically. 
 

 
Figure 20 
 

Saving 
When all game information is added, you can save them in a file for the next round(s). The only way to 
save is to PGN, but ToMaPro saves automatically a file with same name and the extension .TOMA. 
Saving is done through the File -> Save all games  menu, see Figure 21. 
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Figure 21 
 

   
Figure 22 
 
 

ToMa Traditional Display Client 
The ToMa Traditional Display Client (TDC) a game can be shown on any computer in the network. 
This can be one game full screen or multiple games per monitor. 
 
The TDC can be started from the ToMaPro menu Windows – Display Client  or from the start menu. 
The last option is the only way to start it on a computer where ToMaPro does not run. 
 

 
Figure 23 
 
It is possible to run multiple instances of TDC on one computer.  
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For displaying multiple TDC on a monitor you need a monitor of projector with enough resolution. 
Current monitors can show easily 4 games at a time. 
To couple a game to TDC each TDC needs to have a unique name. Use the key combination [CTRL]-
[SHIFT]-[F12] for the following view: 
 

 
Figure 24 
 
Select the Name of channel by double clicking the name and type a new name. If you have multiple 
TDCs an index number is added between square brackets if the name already exists. If the name is 
changed when ToMaPro is running, the new name will be added to the list and the old name is not 
removed.  
 
The list inside ToMaPro can quickly become large and complex. When you need more than 3 TDCs 
open, the best way to do this is by starting them from the Start menu and give them a useful name, 
before starting ToMaPro.  
 
The key [F11] is used for toggling the window edges and (not) showing the menu. With the edges 
showing it is possible to change the size of the window. 
 
The next example shows 4 TDCs on one screen. First image is with edges to change the size and 
position (see Figure 26). The second image after pressing [F11] (see Figure 27). 
 
In ToMaPro the TDCs are controlled through changing the game information form (Edit Game ). The 
Morozevich against Aronian game shows in the ‘rechtsboven’ TDC. Which is the upper right TDC in 
English. 
 
There is some difficulty in getting the screens in equal size and correct location. With some “trial and 
error” Figure 27 can be created. 
 
When the layout is as wanted, do not press [F11] again, because the edges return and the size of the 
windows change ! The tedious creation of the layout has to be done again. 
 

 
Figure 25 
 
A game can be shown on multiple TDCs by selecting multiple clients in the Broadcast settings . 
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TDC Key (combinations) 
[CTRL]+[SHIFT]+[F12] Change the name 
 [F11] Show edges and menu 
[ALT]+[F4] Close the window (default Windows behaviour) 
 
In the example in Figure 26 and Figure 27 the TDCs have been put as good as possible on the 
screen. You get the second figure after clicking each screen and pressing the key [F11]. 
 

 
Figure 26 
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Figure 27 

Publishing live on the web 
ToMa is capable of publishing games live to the internet. An Adobe Flash application is used to show 
a chess board, 5 full moves and a list of boards. Publishing is done per round, even if just one game is 
shown on the web. With a license multiple boards can be shown, with a maximum number of boards 
depending on the license bought. 
 
In the “Edit Round” form a directory is chosen or created by a name in the text field Directory name. 
 
Important are also the Refresh Speed and Maximum polling interval. The Flash Display Client will poll 
the website in a frequency given by these numbers. If these values are wrong, your web site can 
become slow and even crash. Together with the size of the files for the live games, these timing 
values can create a high bandwidth usage! 
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Figure 28 
 
Now click on the button “Live upload…”. 
The ToMa FTP Uploader (FTPuP) will now start. The tab Settings is always the first to show in the 
FTPuP. 
 

 
Figure 29 
 
The windows can look like Figure 29. Check for equal directory names in the text field Local source 
directory or file in the FTPuP and Create ToMa Flash Display site in the Edit Round  form. In the text 
field Remote directory on FTP the name of the directory on the web site is given. If this directory does 
not exist on the web server, it will be created automatically. This directory name is case sensitive  and 
the directories are divided by a forward slash (‘/’) . 
 
The host name 
If the web site is http://www.dgtprojects.com the name to fill out should be www.dgtprojects.com. 
Further you need the user name and password for accessing the FTP on this domain. Normally this is 
given to you by your internet hosting provider. 
 
The Passive FTP checkbox is normally not selected. In some cases, when using firewalls or other 
network security measures, it is necessary to check this checkbox. 
 
Most internet hosting providers allow up to 3 parallel connections on the FTP. Therefore “3” is an 
optimal value for speed and bandwidth for the Maximum FTP connections allowed. See Figure 29. 
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Figure 30 
 
Tab Start 
The word “Start”, including the green arrow on the left, is a button to start uploading the files in the 
selected directory (see Figure 30). You will see the button if you move the mouse pointer over the text. 
After clicking the FTPuP will try to copy the files from the local directory to the remote directory. The 
progress of copying is shown below in the window. 
 
If the message “source path or file does not exists” is shown, than the path filled out in the text field 
“local source directory or file” is incorrect.  
 
If the progress window looks like Figure 31, then uploading has gone wrong. If the progress window 
shows looks like Figure 32, then the uploading is all right. However, it is possible that the error is 
hidden, because the list of files is too long. In such case make the window larger, so you can see all 
files without scrolling. 

Do not stop the FTPuP 
Leave the FTPuP running until ToMaPro is closed. Otherwise changes in games are not uploaded to 
the web site anymore.  FTPuP must always been closed independent from ToMaPro. 
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Figure 31 
 

 
Figure 32 
 
An error during upload can have several causes. Check all information in the tab Settings thorough 
and check also the internet connection. If necessary, check the FTP server with a separate FTP 
program, using the host name, user name and password used in FTPuP.  

Starting a new round 
Before you start a new round, save the current situation. This is independent from saving the games to 
separate PGN. Use File -> Save …  or File -> Save all games…  
 
A new round is started by restarting ToMaPro. This takes care of not losing the board information. The 
other settings must be done again. This is the fastest way to do if a new round is due to start. 
 
A new round can also be started by creating as many new games as there are electronic chess 
boards for the round. The information for each game must be added. In some cases information can 
be copied from the previous round. Important is that as soon as possible the correct boards are added 
to the games. This is done in the Edit Game form with a drop-down box, see Figure 33. 
 

 
Figure 33  

Importing settings from file 
As it often not known in advance who plays who in the next round, the settings can be imported from 
file. This makes adding the names easier. The base file can be created by ToMaPro when from the 
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menu File -> Save  is chosen. Together with the PGN file automatically a file with the extension .TOMA 
is created. 
 
An unedited TOMA file can look as below: 
 
<event>WCC 2007 
<site>Mexico 
<round>WCC 2007 Round 1 
<players>1.1; KRAMNIK, Vladimir (RUS); SVIDLER, Pet er (RUS) 
<record>1.1; DGT4241 
<results>1.1;1/2-1/2 
<positions>1.1; rnbqkbnrpppppppp32PPPPPPPPRNBQKBNR;  45N16.; 11.15p; 35P15.; 6.14n; 
34P15.; 10.7p; 42N14.; 12.7p; 30B27.; 15.7p; 21B8.;  3.17q; 44P7.; 1.9n; 43B17.; 
14.7p; 36P7.; 27.6p; 28P7.; 12q8.; 34B8.; 5.8b; 60. RK.; 4.rk.; 60R.; 3r1.; 52Q6.; 
9.7p; 56.2R; 8.15p; 34.8B; 2.6b; 36B6.; 17.7p; 39P1 5.; 11.5n; 36.20B; 18.7p; 
25N16.; 9.6b; 31P7.; 22.7p; 45.9N; 3.31r; 35R23. 
 
<event>WCC 2007 
<site>Mexico 
<round>WCC 2007 Round 1 
<players>1.2; MOROZEVICH, Alexander (RUS); ARONIAN,  Levon (ARM) 
<record>1.2; DGT4247 
<results>1.2;1/2-1/2 
<positions>1.2; rnbqkbnrpppppppp32PPPPPPPPRNBQKBNR;  35P15.; 6.14n; 34P15.; 12.7p; 
45N16.; 9.7p; 40P7.; 2.6b; 42N14.; 11.15p; 27P6.; 2 1.5n; 44P7.; 14.7p; 39P15.; 
5.8b; 31P7.; 1.9n; 43B17.; 27.14n; 42P6.; 20.7p; 50 Q8.; 3.8q; 36B6.; 9.26b; 36Q13.; 
4.rk.; 22P8.; 15.6p; 32P7.; 10.15p; 40B17.; 4r.; 56 .1R; 28.6p; 12Q23.; 4.7r; 35P6.; 
12.23r; 60.K; 26.8p; 35P8.; 5n5.; 46P7.; .2r; 10R47 .; 4r31.; 8R1.; r2. 
 
For creating the import file, it can be put into another sequence, like the example below: 

1. The name en location of the tournament 
2. The round information (per round). Do not forget to add one for the next round. 
3. The e-board serial numbers per table number. These do not have to change during the 

tournament. There is of course always a possibility to exchange e-boards for a reason. 
4. The names of the TDC per table, which normally do not change during the tournament. 

 
The names of the player can be added. Use copy and past from other Windows sources. All 
information per line is divided by a semicolon (‘;’). 
<event>WCC 2007 
 
<site>Mexico 
 
<round>WCC 2007 Round 1 
<roundweb>c:\documents and settings\paul\documenten \toma\wcc 2007\Round 1\;10 
<roundpgn>c:\documents and settings\paul\documenten \toma\wcc 2007\WCC 2007 WCC 2007 
Round 1.pgn 
 
<record> 
1; DGT4241 
2; DGT4247 
3; DGT4356 
4; DGT4268 
 
<tv> 
1;display0 
2;display1 
3;display2 
4;display3 
 
 
<players> 
1; KRAMNIK, Vladimir (RUS); SVIDLER, Peter (RUS) 
2; MOROZEVICH, Alexander (RUS); ARONIAN, Levon (ARM ) 
3; ANAND, Viswanathan (IND); GELFAND, Boris (ISR) 
4; GRISCHUK, Alexander (RUS); LEKO, Peter (HUN) 
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The game names (or table names) are shown as a single number in the above example.  For each 
‘table’ in each of the blocks <record>, <tv> and <players> the information like player name, TDC name 
or serial number of the e-board is added. Under <players> the first player name is the player who 
plays the white pieces. 
 
Remember to save the file with the .TOMA extension and file type “All”. With another extension like .txt 
ToMaPro will not recognize the file. 
 

 
Figure 34 
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Solving problems 

Problem: the moves of a game are not recorded. 
The right board, containing the game, is still in the start position. The left board shows that the actual 
position on the board is different. The recording signal above the notation field shows “OFF” or 
“manual”. See Figure 35. 
 

 
Figure 35 

Solution 
The recording of the game can only start when the positions on both boards are equal. In Figure 35 
moves are already played on as can seen on the left board. The right board is still in starting position. 
To make both boards equal, the correct scan must be found on the left board. The easiest way to do 
this is by clicking on the “Search position” button. This is the button with the right pointing arrow sign. 
This can only work, if the position on the right board is available as a scan. 

Operations 
·  Click on the button "Search position", the left board will show the position on the right board if 

it is available in the scans. 
·  Click on the button "record from here" below the left board (see Figure 36). 

 

 
Figure 36 
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·  Activate the move recording and acknowledge with ‘Yes” (see Figure 37).  
 

 
Figure 37 
 

·  Repeat the above sequence of operations for all other boards if necessary. 

Problem: the game starts before all information is added 
You did not have time yet to add all new round information into ToMaPro. 

Solution 1 
The first time new games are automatically created when ToMaPro is started. The next rounds the 
information must be added manually. And sometimes adding information must be done quickly, 
because the next round is already starting. To add a new round quick handle as follows: 

- Press [CTRL]-[n] as often as there are e-boards attached. 
- Double click on every game and choose an e-board from the drop down menu (see Figure 

38). 
- Click "OK” 

 

 
Figure 38 
 
Leave the other fields blank, these can be filled out later when the games are started. 
 

Solution 2 
Save the ToMaPro information to file by selecting File – save all games in the menu. Then close 
ToMaPro and restart ToMaPro again. The BoCo information will automatically generate new games  
for the available boards. 
 
Do not forget to enable move recording in the Edit Round form. 
 

 
Figure 39  
 
The round can start immediately; the other information can be added later without influencing the 
recording of the games. Information added will be shown immediately on the TDC or TFD. 
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Solution 3 
The best way is preparing a text file for each round containing the tournament information, player 
names, etc. See Importing settings from file. 

Problem: players put the pieces not well on a field  
A player puts a piece on the border of two fields or off the board. It is not recognized anymore by the 
board. ToMaPro knows that a piece is removed from the board, but cannot determine where it is put 
back on the board. 
 
In the example in Figure 40 white plays e2-e4, followed by blacks e7-e5. Now white puts the d2 pawn 
on the border of d3 and d4. On the left board with the scans, the white pawn disappeared from the d-
line. The move reconstructor is now unable to reconstruct a legal move. Therefore it shows on the 
right board the error piece with a blue background.  
 

 
Figure 40 
 
When black now plays d7-d6, the move will not be recorded yet. The program thinks that white has not 
yet played a move. Every difference between the left board and right board will be shown with a blue 
background in the right board. 
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Figure 41 
 
Now white plays f2-f3, which a is legal move. And now blacks move is considered legal, resulting in 
Figure 42. The sequence of moves is now incorrect, but the game can continue in ToMaPro. Behind 
the move in the move notation window there is a number between brackets. This is the number of 
differences between the left and right board. 
 

 
Figure 42 
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Now white sees that the pawn is placed wrongly and positions it on d3. Being the second move of the 
game, it will now be shown in ToMaPro as move 3. The positions on both boards are now the same, 
but there is a different and incorrect move sequence, see Figure 43. 
 

 
Figure 43 
  
The game can now continue and recording is still on. 
 

 
Figure 44 
 

Move list corrections 
During solving problems in some cases the moves cannot be reconstructed by the automatic 
reconstruction mechanism. Reason could be missing scans. To correct this situation there are two 
possibilities: 
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1. Select a piece in the right board. All possible legal fields show now up in red and purple. 
Select one of the coloured fields for making the move.  Figure 45. 

2. In the game notation field, right click on a move. Now you have several possibilities, including 
deleting everything from this move. If you select move showing ‘*’ you can select the wanted 
move from a list of legal moves. Figure 46. 

 
With the second method it is possible to add a result, deleting move sequences, save to PGN and 
disabling/enabling the move recording. 
 

 
Figure 45 
 

 
Figure 46 

Setting the desired order of games in the ToMa Flas h Display on the 
Internet 

Problem: 
When you alter the order of games in ToMa Pro, this order is not displayed on the internet display. 
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ToMa Pro will read in the games in the same order as the Board Communicator (BoCo). This order will 
internally be preserved and cannot be altered. 

Solution: 
·  Start the BoCo and select the proper port. 
·  Wait until all boards are shown under the "active" heading. 
·  Press the connect  button 
·  Start ToMa Pro 
·  Enter all information you want for the:  

o Tournament 
o Round 
o Games 

 
You can now sort the games by clicking on a heading in the table. In the example we clicked on the 
"game" heading. 
Notice that the column width can be altered by dragging the (invisible) border between the headings, 
you may also want to enlarge the whole window. 
The clock times will not be shown until the clocks are actually running 
 

 
 

·  Save this tournament by selecting File – save…  
 

 
 

·  Close ToMa Pro 
·  Close the BoCo 

 
·  Start ToMa Pro without starting the BoCo 
·  Choose File – open 
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·  Select the filename you just saved (you can either open the PGN file or choose the ToMa 
extention in the filetype textbox.) The .toma file contains some more data about the games, 
but the pgn file will do the job also. 

 
You will see all the games in ToMa pro as you saved them, only there is no connection yet to the 
boards. You can see this because the board identification is in angle brackets ("<" and ">") 
 

 
 
Start the BoCo 
Select the proper port 
Wait until all boards are connected 
Press the connect  button 
You will see that all board numbers stripped off the angle brackets and are followed by OK 
 

 
 

Because the order is now dictated by the saved PGN file, the order in the ToMa flash Display 
(TFD) will also be this desired order. 
When you already made a tfd folder, it is best to remove this first before making a new one in the 
"edit round" dialog box. 
 
Don't forget to alter the html of the tfd.htm if you have more than 6 games to show. In this 
example: 
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 #livegames 
 { 
  width: 600px; 
  height: 650px; 
  border: 1px solid black; 
  padding: 5px; 
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Definitions 
PGN Portable Game Notation, an international pro forma standard for storing chess 

games in a text file. Per file one or more games can be stored. 
ToMa DGT – Tournament Manager. The set of programs to record chess games from 

e-boards and publish them. 
ToMaPro The server program and user interface for the ToMa. 
BoCo Board Communicator, the communicator between the computer and the 

electronic boards. 
TFD ToMa Flash Display, a Flash animation for publishing the games on internet. 

Remark: this does not use PGN but a special format. 
TDC ToMa Display Client, a program to show a game on a local monitor. It can be 

showing the game full screen. 
LAN Computer world: Local Area Network.  

Chess world: Long Algebraic Notation, e.g. Ka1-b2. 
SAN Short Algebraic Notation, e.g. Kb2 
FTP  File Transport Protocol, a standard protocol for transferring files between 

computers, often used for putting files on a web site. 
FTP uploader ToMa FTP file uploader, which check a directory for changes and publish the 

contents on internet. 
Chess960 Also know as Fischer Random Chess. The officers of the chess game can be in 

one of the 960 positions put on the board. See Chess960 or 
http://en.wikipedia.org/wiki/Chess960  
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Appendices 

Register ToMa 
Using ToMa unregistered only one board can be published on the internet and locally. For using it with 
multiple boards a registration key is necessary. This key can be bought at DGT projects. 
 
If you have received your key, the following actions must be taken: 

- Choose in the menu Windows -> Enter Registration Key . The form from Figure 47 will show. 
- Fill out the forms with the information received from DGT. 
- If the key is valid, this is shown in the bottom of the form. 
- Click on ÖK”. 

 

 
Figure 47  
 
After registration the dialog from Figure 48 will be shown. 
 

 
Figure 48 
 
Press [Enter] or click on Yes for restarting the communication. Every time you start ToMaPro, this key 
will be used until another key is entered. The user name will now show in the title of the application 
and in the TFD and TDC screens. 
If you are registering with a temporary key, the program will only be working with multiple boards 
during the period requested. 
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Scheme for board cabling 
For playing a tournament with a great number of boards it is recommended to use serial boards. With 
serial boards a longer distance can be reached (100 meter), whereas USB board only reach 15 meter. 
 
The serial boards can be setup in a bus/star network with a maximum of 12 boards per serial port on 
the PC. 

TOMA
(max. 1) + 
Board 
communicator

Power adapter

Connetion box

PC to bus cable

8 wire
flatcable

(bus)

Connetion box

Board to bus 
cable 1m

Up to 12 
boards per 
COM Port.

Maxiumum
total length of 
buscable per 
COM-port = 
100 m.

COM 
port

RJ-45 
connector

RJ-45 
connector

8 wire
flatcable

(bus)

 
Figure 49 
 

- All boards can have one power supply; this is a special tournament adapter that outputs more 
power than an adapter for one board. 

- The bus cable, with 8 wires (preferable flat cable), has a RJ-45 connector on both sides. The 
connector on both sides of the cable has the same connections. If you place both connectors 
next to each other, the sequence of the coloured wires in the connectors is the same. 

- The cables are connected with each other and the board through connection boxes with tree 
cable connections. It does not matter which cable goes where! 

- The cable length per situation is different. For creating cables on the wanted lengths you can 
order RJ-45 shrink pliers at DGT. 

- To detect cable errors quickly use a network cable tester. It is impossible to test a circuit if a 
connection box is in the circuit. 

 
It is possible to use USB boards. However there is only 3.5 meter cable length available per segment. 
With use of USB hubs the boards can be placed further than 3.5 meter from each other. In Figure 50 a 
computer is connected with 6 USB boards.  
 
It is possible to use two computers. One of the computers runs only a BoCo, the other a BoCo and 
ToMaPro or only ToMaPro. Both computers must be connected through a (wireless) network. 
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Tips for cabling the system 
·  Use the include RJ45 tool for stripping the mantel from the flatcable 
·  After stripping the outer mantel, cut of ± 1 mm of the end of the wires 
·  Watch carefully that you have the same order of colours at each end 
·  Test each segment immediately after crimping the connectors with a LAN tester 
·  Don't connect all boards at once, but test the system in parts by starting the BoCo and check 

the number of boards onder "active". Close the BoCo after each test. 
·  Use stagetape to tape the cables to the floor once the system is up and running 
·  Push the plug of the clock firmly in it. Sometimes failure of a clock is due to a plug that is not 

pushed in enough. 
·  Check the state of the clock batteries before starting a tournament 

 
 

Board 
Commu-
nicator  

 

Figure 50 
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Minimal configuration 
For a typical tournament the following material is needed. A hash (‘#’) stands for the number of 
boards. 
  

- 1 PC with serial connection or USB connection including a Serial-to-USB converter. 
- ToMa installed on a PC with # board license. 
- Internet aansluiting. 
- 1 PC to bus cable. 
- 1 Power adapter 12 V 1000 mA. 
- # DGT electronic chess boards. 
- # Sets DGT chess pieces. 
- # Board to bus cables. 
- # DGT XL chess clocks. 
- # + 2 connection boxes (+ #/5 reserve). 
- # x 4 + RJ 45 connectors (= 1 extra per connection box). 
- # x 10 meter flat cable. 
- 1 pair of RJ-45 connecting pliers. 
- 1 cutting pliers. 
- Tape (preferably stage tape) and tie wraps. 

 
Optional 
 

- 1 network cable tester. 
- Beamer. 
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Editing the ToMa Flash Display page  
 
Standard an internet page is generated. This is all right for displaying approximately 8 games. If you 
want to show more games, these are not directly shown. 
 

 
 
Figure 51 
 
This problem can be overcome by changing the HTML of the page. No intensive HTML knowledge is 
needed for this. The change is the adapting the size of a HTML element: 
 

- Open the file tfd.htm in the web upload directory with an editor. Windows Notepad is all right 
for this action. 

- Search for an item with the name ‘# livegames’. It shows default the value of 550px for the 
heights. Enlarge this value for showing more games in the TFD screen. In the example below 
750px is used. 

 
The HTML code snippet for Figure 51 is show below: 
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The changed HTML code snippet below results in Figure 52: 
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Figure 52 
 
If you have knowledge of HTML and building web pages, you can enhance the page with e.g. 
background color or images of the tournament sponsor. See Figure 53. 
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Figure 53 
 
For the above figure the following HTML code was used: 
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The Flash object is used twice. Important is in this case the width of less than 50%, otherwise the 
objects will show below each other. The background colour of the page is made equal to the colour of 
the flash object. 

Chess960 or Fischer Random Chess 
In 1996 Bobby Fischer presented this form of chess. The castling is still possible. The king must be 
placed between the rooks. The bishops need to be on different colours. Now the number of start 
positions is 960. Normal chess rules apply, where the rochade is treated somewhat special. 
 
For more information look at http://www.chess960.nl/. 

Basic Chess 

The rules  
I. The rooks and pawns of both players are on the board before the beginning of the game. Just like 
their positions with classical chess. 
 
II. During the first six moves the other pieces are placed on the board. Each of the pieces comes on 
the backline on the open fields. 
 
III. There are to restrictions: the bishops are placed on fields of different colour and the king must be 
placed on the d-line or e-line (white: d1 or e1; black d8 or e8). The short castling depends on the 
position of the king!  
 
IV. Placing the pieces on the board must be finished before any of the pieces may be used to move on 
the board. 
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